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Welcome to Dreamweaver  
Macromedia Dreamweaver MX is a professional HTML editor for designing, coding, and 
developing websites, web pages, and web applications. Whether you enjoy the control of hand-
coding HTML or prefer to work in a visual editing environment, Dreamweaver provides you 
with helpful tools to enhance your web creation experience.  

The visual editing features in Dreamweaver let you quickly create pages without writing a line of 
code. You can view all your site elements or assets and drag them from an easy-to-use panel 
directly into a document. You can streamline your development workflow by creating and 
editing images in Macromedia Fireworks, then importing them directly into Dreamweaver, or by 
adding Macromedia Flash objects you create directly in Dreamweaver.  

Learning Dreamweaver  

Dreamweaver includes a variety of resources to help you learn the program quickly and become 
proficient in creating your own websites and pages. These resources include a printed Getting 
Started guide, an online help system, and tutorials. In addition, you can find regularly updated 
tips, TechNotes, examples, and information at the Dreamweaver Support Center on the 
Macromedia website.  

Dreamweaver Support Center  
To help you get the most out of Dreamweaver, you can consult a web-based support center. The 
Dreamweaver Support Center website is updated regularly with the latest information on 
Dreamweaver, plus advice from expert users, examples, tips, updates, and information on 
advanced topics. Check the website often for the latest news on Dreamweaver and how to get the 
most out of the program.  
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Dreamweaver's Workspace Layout 
In Windows, Dreamweaver provides an all-in-one-window integrated layout. In the integrated 
workspace, all windows and panels are integrated into a single larger application window. 

 

Dreamweaver Workspace Elements 
TIP: Dreamweaver provides many other panels, inspectors, and windows. To open 
Dreamweaver panels, inspectors, and windows, use the Window menu. If you can’t find a panel, 
inspector, or window that’s marked as open, select Window > Arrange Panels to neatly lay out 
all open panels. 

The Insert bar contains buttons for inserting various types of "objects," such as images, tables, 
and layers, into a document. Each object is a piece of HTML code that enables you to set various 
attributes as you insert it. For example, you can insert a table by clicking the Table button in the 
Insert bar. If you prefer, you can insert objects using the Insert menu instead of the Insert bar. 
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The Document toolbar contains buttons that provide options for different views of the 
Document window (such as Design view and Code view), various viewing options, and some 
common operations such as previewing in a browser. 

The Standard toolbar (not displayed in the default workspace layout) contains buttons for 
common operations from the File and Edit menus: New, Open, Save, Save All, Cut, Copy, Paste, 
Undo, and Redo. To display the Standard toolbar, select View > Toolbars > Standard. 

The Document window displays the current document as you create and edit it. 

The Property inspector lets you view and change a variety of properties for the selected object 
or text. Each kind of object has different properties. The Property inspector is not expanded by 
default in the Coder workspace layout. 

The tag selector in the status bar at the bottom of the Document window shows the hierarchy of 
tags surrounding the current selection. Click any tag in the hierarchy to select that tag and all 
its contents.  

Panel groups are sets of related panels grouped together under one heading. To expand a panel 
group, click the expander arrow at the left of the group’s name; to undock a panel group, drag the 
gripper at the left edge of the group’s title bar. 

The Files panel enables you to manage your files and folders, whether they are part of a 
Dreamweaver site or on a remote server. The Files panel also enables you to access all the files 
on your local disk, much like Windows Explorer (Windows) or the Finder (Macintosh).  

 

The Document Window 
The Document window shows the current document. You can select any of the following views: 

Design view is a design environment for visual page layout, visual editing, and rapid application 
development. In this view, Dreamweaver displays a fully editable, visual representation of the 
document, similar to what you would see viewing the page in a browser.  

Code view is a hand-coding environment for writing and editing HTML, JavaScript, server-
language code--such PHP or ColdFusion Markup Language (CFML)--and any other kind of 
code.. 

Code and Design view enables you to see both Code view and Design view for the same 
document in a single window. 
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Design View of the Document Window 

 

When the Document window has a title bar, the title bar displays the page title and, in 
parentheses, the file’s path and filename. After the filename, Dreamweaver displays an asterisk if 
you’ve made changes that you haven’t saved yet. 

When the Document window is maximized in the integrated workspace layout (Windows only), 
it has no title bar; in that case the page title and the file’s path and filename appear in the title bar 
of the main workspace window. 

When a Document window is maximized, tabs appear at the top of the Document window area 
showing the filenames of all open documents. To switch to a document, click its tab. 
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Toolbars 

The Document Toolbar 

 

The Document toolbar contains buttons that let you toggle between different views of your 
document quickly: Code, Design, and a split view that shows both Code and Design view.  

The toolbar also contains some common commands and options related to viewing the document 
and transferring it between the local and remote sites. 

The Standard toolbar 

 

The Standard toolbar contains buttons for common operations from the File and Edit menus: 
New, Open, Save, Save All, Cut, Copy, Paste, Undo, and Redo. Use these buttons just as you 
would use the equivalent menu commands. 

 

The Status Bar 

The status bar at the bottom of the Document window provides additional information about the 
document you are creating. 

The tag selector shows the hierarchy of tags surrounding the current selection. Click any tag in 
the hierarchy to select that tag and all its contents. Click <body> to select the entire body of the 
document. To set the class or id attributes for a tag in the tag selector, right-click (Windows) or 
Control-click (Macintosh) the tag and select a class or ID from the context menu. 

The Window Size pop-up menu (visible in Design view only) lets you resize the Document 
window to predetermined or custom dimensions.  

To the right of the Window Size pop-up menu are the estimated document size and estimated 
download time for the page, including all dependent files such as images and other media files 
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The Insert Bar 

 

The Insert bar contains buttons for creating and inserting objects such as tables, layers, and 
images. When you roll the pointer over a button, a tooltip appears with the name of the button. 

 

 

The buttons are organized into 
several categories, which you can 
switch on the left side of the Insert 
bar by clicking the list arrow  

When you start Dreamweaver, the 
category you were last working 
in opens..  

 

 

Some categories have buttons with pop-up menus. When you select an option from a pop-up 
menu, it becomes the default action for the button. For example, if you select Image Placeholder 
from the Image button’s pop-up menu, the next time you click the Image button, Dreamweaver 
inserts an image placeholder. Anytime you select a new option from the pop-up menu, the 
default action for the button changes. 

The Insert Bar is organized into the following categories: 

The Common category enables you to create and insert the most commonly used objects, such 
as images and tables.  

The Layout category enables you to insert tables, div tags, layers, and frames. You can also 
you choose among three views of tables: Standard (default), Expanded Tables, and Layout. 
When Layout mode is selected, you can use the Dreamweaver layout tools: Draw Layout Cell 
and Draw Layout Table.  

The Forms category contains buttons for creating forms and inserting form elements.  
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The Text category enables you to insert a variety of text- and list-formatting tags, such as b, em, 
p, h1, and ul.  

The HTML category enables you to insert HTML tags for horizontal rules, head content, tables, 
frames, and scripts.  

Server-code categories are available only for pages that use a particular server language, 
including ASP, ASP.NET, CFML Basic, CFML Flow, CFML Advanced, JSP, and PHP. Each of 
these categories provides server-code objects that you can insert in Code view.  

The Application category enables you to insert dynamic elements such as recordsets, repeated 
regions, and record insertion and update forms. 

The Flash elements category enables you to insert Flash elements. 

The Favorites category enables you to group and organize the Insert bar buttons you use the 
most in one common place.  

 

The Property Inspector  
The Property inspector lets you examine and edit the most common properties for the currently 
selected page element, such as text or an inserted object. The contents of the Property inspector 
vary depending on the element selected. 

 

Tip: The Property inspector is at the bottom of the workspace by default, but you can dock it at 
the top of the workspace if you want. Or, you can make it a floating panel in the workspace.. 

To show or hide the Property inspector: 

• Select Window > Properties.  

To expand or collapse the Property inspector: 

• Click the expander arrow in the lower right corner of the Property inspector.  
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To view properties for a page element: 

• Select the page element (e.g. a section of text or an image) in the Document window.  

Note: You might need to expand the Property inspector to view all the properties for the 
selected element. 

To change properties for a page element: 

1. Select the page element (e.g. a section of text or an image) in the Document window.  

2. Change any of the properties in the Property inspector.  

Note: For information on specific properties, select an element in the Document window 
and then click the Help icon in the upper right corner of the Property inspector. 

Most changes you make to properties are immediately applied in the Document window.  

3. If your changes are not applied immediately, do one of the following:  
o Click outside the property-editing text fields.  
o Press Enter (Windows) or Return (Macintosh).  
o Press Tab to switch to another property.  
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Using Panels and Panel Groups  

 

Panels in Dreamweaver are grouped together 
into panel groups. The selected panel within a 
panel group appears as a tab. Each panel group 
can be expanded or collapsed, and can be 
docked or undocked with other panel groups.  

Panel groups can also be docked to the 
integrated application window (Windows 
only). This makes it easy to access the panels 
you need without cluttering your workspace.  

Note: When a panel group is floating 
(undocked), a narrow blank bar appears at the 
top of the panel group. In this documentation, 
the term "panel group’s title bar" refers to the 
area where the panel group’s name appears, 
rather than to this narrow blank bar. 

Viewing panels and panel groups 

You can display or hide panel groups and 
panels in the workspace as necessary.  

To expand or collapse a panel group, 
do one of the following: 

• Click the expander arrow on the left 
side of the panel group’s title bar. 

• Click the panel group’s title.  

 

To close a panel group so that it isn’t visible on your screen: 

• Select Close Panel Group from the Options menu in the panel group’s title bar. 
The panel group disappears from your screen. 
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To open a panel group or panel that isn’t visible on your screen: 

• Select the Window menu, then select a panel name from the menu.  A check mark next to 
an item in the Window menu indicates that the named item is currently open (though it 
may be hidden behind other windows).  

Tip: If you can’t find a panel, inspector, or window that’s marked as open, select 
Window > Arrange Panels to neatly lay out all open panels. 

To select a panel within an expanded panel group: 

• Click the panel’s name.  

To see a panel group’s Options menu if it isn’t showing: 

• Expand the panel group by clicking its name or its expander arrow. 
The Options menu is visible only when the panel group is expanded.  

Copyright 2003 Macromedia®  Page 12 
Excerpted from Macromedia Dreamweaver® MX 2004 Help  Document 



Setting Up a Dreamweaver Site 
A website is a set of linked documents and assets with shared attributes, such as related topics, 
a similar design, or a shared purpose. Macromedia Dreamweaver MX 2004 is a site creation 
and management tool, so you can use it to create complete websites, in addition to 
individual documents.  

The first step in creating a website is planning. For best results, design and plan the structure of 
your website before you create any of the pages that the site will contain. 

The next step is to set up Dreamweaver so that you can work on the basic structure of the site. If 
you already have a site on a web server, you can use Dreamweaver to edit that site. 

About Dreamweaver sites 

A Dreamweaver site provides a way to organize all of the documents associated with a website. 
Organizing your files in a site enables you to use Dreamweaver to upload your site to the web 
server, automatically track and maintain your links, manage files, and share files. To take full 
advantage of Dreamweaver features, you should define a site. 

A Dreamweaver site consists of as many as three parts, or folders, depending on your 
development environment and the type of website you are developing: 

The local folder is your working directory. Dreamweaver refers to this folder as your "local 
site." This folder can be on your local machine or it can be on a network server. It is where you 
store the files you are working on for a Dreamweaver site.  

All you need to do to define a Dreamweaver site is set up a local folder. To transfer files to a web 
server or to develop web applications, you need to also add information for a remote site and 
testing server. 

The remote folder is where you store your files, depending on your development environment, 
for testing, production, collaboration, and so on. Dreamweaver refers to this folder as your 
"remote site" in the Files panel. Typically, your remote folder is on the machine where your web 
server is running. 

Together, the local and remote folders enable you to transfer files between your local disk and 
web server; this makes it easy for you to manage files in your Dreamweaver sites. 
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Setting up a new Dreamweaver site  
 

1. Select Site > Manage Sites.  

 

The Manage Sites dialog box appears. 
Note: If you don’t have any 
Dreamweaver sites defined, then the 
Site Definition dialog box appears and 
you can skip the next step. 

 
  

 

2. Click the New button.  

The Site Definition dialog box appears. If the dialog box is showing the Advanced tab, 
click Basic.  The first screen of the Site Definition Wizard appears, asking you to enter a 
name for your site.  
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1. In the text box, enter a name to identify the site within Dreamweaver. Click Next to 
proceed to the next step. 

2. The next screen of the wizard appears, asking if you want to work with a server 
technology.   Select the No option to indicate that for now, this site is a static site, with no 
dynamic pages. 

3. Click Next to proceed to the next step. 

4. The next screen of the wizard appears, asking how you want to work with your files. 
Select the option labeled “Edit local copies on my machine, then upload to server when 
ready (recommended).” 
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This option allows you to have a “working” copy of your site stored locally on your own 
computer, which you can then publish to a web server location when you ar ready.  You 
can use the local working copy to makes changes and do ongoing maintenance to your 
site without worrying about harming the active web site.  When your changes are 
complete on the local copy, you simply transfer it to the server. (see Publishing Your 
Web Site) 
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1. The text box allows you to specify a folder on your local disk where Dreamweaver 
should store the local version of the site’s files. It’s easier to specify an accurate folder 
name if you browse to the folder rather than typing the path, so click the folder icon next 
to the text box. 

The Choose Local Root Folder for Site dialog box appears.  

 

 

2. In the Choose Local Root Folder for Site dialog box, start by navigating to a folder on 
your local disk where you can store all of your sites. and click OK to close the Choose 
Local Root Folder for Site dialog box. 

Click Next to proceed to the next step. 

The next screen of the wizard appears, asking how you connect to your remote server.  
The remote server location is where you will publish your web site. You can either set up 
the remote location now, or do it later by selecting none here. 

3. For now, choose None from the pop-up menu. Click Next to proceed to the next step. 
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The next screen of the wizard appears, showing a summary of your settings.  

4. Click Done to finish. 

You can set up information about your remote site later; for now, the local site 
information is all you need to start creating a page.  
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The Manage Sites dialog box is redisplayed, 
showing your new site name.  Click Done to 
complete the site creation. 

 
 

The Site panel now shows the new local root 
folder for your current site 

 

The Site panel normally shows all the files and folders in your site, but right now your site 
doesn’t contain any files or folders. When there are files in a site, the file list in the Site panel 
acts as a file manager, allowing you to copy, paste, delete, move, and open files just as you 
would on a computer desktop.  

If you already have a set of local HTML files that you want to use to create a website, you can 
use the file browser in the Site panel to copy those files into your newly created site’s folder.  

Note: You can also edit files without setting up a Dreamweaver site.   
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Editing Existing Websites in Dreamweaver 
You can use Dreamweaver to edit existing sites, even if you didn’t use Dreamweaver to create 
the original site. You can edit existing sites that are on your local system or sites that are on a 
remote system. 

Editing an existing local website in Dreamweaver 

You can use Dreamweaver to edit an existing website on your local disk, even if you didn’t use 
Dreamweaver to create the original site. 

To edit an existing local website: 

1. Select Site > Manage Sites.  

The Manage Sites dialog box appears. 

2. Click New.  

The Site Definition dialog box appears. 

3. Click the Advanced button, if the Advanced settings aren’t showing.  The Advanced tab 
of the Site Definition dialog box displays the Local Info category options. 

4. Complete the dialog box.  

5. Click OK.  

 

Editing an existing remote website in Dreamweaver 

You can use Dreamweaver to copy an existing remote site (or any branch of a remote site) to 
your local disk and edit it there, even if you didn’t use Dreamweaver to create the original site. 

. 

To edit an existing remote site:  

1. Create a local folder to contain the existing site, then, using the Manage Sites dialog box,  
set it up as the local folder for the site. 

2. Set up a remote folder, using information about your existing site.  Make sure to choose 
the correct root folder for the remote site. 
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3. In the Files panel (Window > Files), click the Connects to Remote Host button (for FTP 
access) or the Refresh button (for network access) in the toolbar to view the remote site.  

4. Depending on how much of the remote site you want to edit, do one of the following:  

o If you want to work with the entire site, select the root folder of the remote site in 
the Files panel, then click Get in the toolbar to download the entire site to your 
local disk.  

o If you want to work with just one of the files or folders of the site, locate the file 
or folder in the Remote view of the Files panel, then click Get in the toolbar to 
download that file to your local disk.  

Dreamweaver automatically duplicates as much of the remote site’s structure as is 
necessary to place the downloaded file in the correct part of the site hierarchy. When 
editing only one part of a site, you should generally choose to include dependent files. 

5. Use Dreamweaver to work on your site.  
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Creating a New Web Page 
In Dreamweaver, web pages are referred to as documents. 

To create a new blank document: 

1. Select File > New.   The New Document dialog box appears. The General tab is already 
selected. 

 

2. From the Category list, select Basic Page. 

3. Click the Create button.   The new document opens in the Document window. 

4. Save the document.  
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Creating a Document Based on a Dreamweaver Design File 

Dreamweaver comes with several professionally developed page layout and design element files. 
You can use these design files as starting points for designing pages in your sites. When you 
create a document based on a design file, Dreamweaver creates a copy of the design file fro you 
to work with. 

To create a new document from a Dreamweaver design file:  

1. Select File > New.  

The New Document dialog box appears. The General tab is already selected. 

2. In the Category list, select CSS Style Sheets, Table Based Layouts, Page Designs (CSS), 
Page Designs, or Page Designs (Accessible); then select a design file from the list on the 
right.  

You can preview a design file and read a brief description of a document’s design 
elements. 

3. Click the Create button.  

The new document opens in the Document window. If you selected a CSS style sheet, the 
CSS document appears in the Document window and the CSS Style Sheet opens in Code 
view. 

4. Save the document. 

If the file contains links to asset files, the Copy Dependent Files dialog box appears for 
you to save a copy of the dependent files. 

5. If the Copy Dependent Files dialog box appears, set options, then click Copy to copy the 
assets to the selected folder.  

You can choose your own location for the dependent files or use the default folder 
location Dreamweaver generates (based on the design file’s source name). 

 

Opening Existing Documents  
In Dreamweaver, you can open an existing web page or text-based document, even if it wasn’t 
created in Dreamweaver. You can open the document and use Dreamweaver to edit it in either 
Design view or Code view. 
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If the document you open is a Microsoft Word file that was saved as HTML, you should use the 
Cleanup Word HTML command to remove the extraneous markup tags Word inserts into HTML 
files. 

You can also open non-HTML text files, such as JavaScript files, XML files, CSS Style Sheets, 
or text files saved by word processors or text editors.  

To open an existing file: 

1. Select File > Open.   The Open dialog box appears. 

2. Navigate to and select the file you want to open.  

3. Click Open.   The document opens in the Document window.  

4. If you opened a Microsoft Word document, select Commands > Clean Up Word HTML, 
and then click OK.   There might be a slight delay while Dreamweaver attempts to 
determine which version of Word was used to save the file. If Dreamweaver is unable to 
determine this, select the correct version using the pop-up menu.  Dreamweaver applies 
the cleanup settings to the new document and a log of the changes appears. 

 

Importing a Microsoft Office File 
In Dreamweaver, you can import documents saved by Microsoft Word or Excel.  Word 
documetns can be cleaned with the Clean Up Word HTML command to remove the extraneous 
HTML code generated by Word. Excel worksheets are imported as tables; any cosmetic 
foprmatting that was done in Excel is omitted in the imported copy. 

To import a Microsoft Word or Excel file:  

1. If you haven’t already, in Microsoft Word, save your document as an HTML file.  
2. In Dreamweaver, select File > Import > and cthen choose either Word Document or 

Excel Workbook.  

The Open dialog box opens. 

3. Navigate to and select the file you want to open.  

If the document is a Word file, the document opens and the Clean Up Word HTML 
dialog box appears. 

If the file is an Excel worksheet, the contents is imported as a table. 
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Copying and pasting text from MS Office documents 

You can also add the contents of a Word or Excel document to a new or existing web page using 
copy/paste. 

Note: The file size, after Dreamweaver converts it to HTML, must be less than 300K. 

When you paste content to a page, Dreamweaver converts the content to HTML and copies it to 
your web page. You can edit the content in Dreamweaver; changes you make to the original file 
on your computer will not appear on your website. 

To add the contents of a Word or Excel document to a new or existing web 
page: 

1. Open the web page that you want to copy the contents of the Word or Excel file to.  
2. Do one of the following to select the file:  

o Drag the file from its current location to the page where you want the content to 
appear. If the Insert Microsoft Word or Excel Document dialog box appears, click 
Insert the contents of the document into this web page, then click OK.  

o Select File > Import > Word Document or File > Import > Excel Document. In 
the Open dialog box, browse to the file you want to add, then click Open.  

The contents of the Word or Excel document appears in your page. 

 

Setting Page Properties 
Page titles, background images and colors, text and link colors, and margins are basic properties 
of every web document. You can set or change page defaults for these by using the Page 
Properties dialog box. 

To set page properties: 

1. Select Modify > Page Properties from the menu, or click the Page Properties button in 
the text Property inspector.  You may also click your right mouse button on the page 
background and select Page Properties from the pop up menu. 

 

The Page Properties dialog box opens. 
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2. Make changes to the page properties, as desired.  

3. Click OK.  

About setting page properties 

For each page you create in Dreamweaver, you can specify layout and formatting properties 
using the Page Properties dialog box (Modify > Page Properties). The Page Properties dialog box 
lets you specify the default font family and font size, background color, margins, link styles, and 
many other aspects of page design. You can assign new page properties for each new page you 
create, and modify those for existing pages 

You may also save these page properties as an external style sheet, which will allow you to 
quickly apply the same settings to other pages in your web site. 
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Saving your Page Properties as an External Style Sheet 

After you have set up the Page Properties for a 
page, Dreamweaver will display a style in the 
Design panel.  The style will contain all of the 
settings that  you selected for the page 
properties. 

To create an external style sheet:  

Click your right mouse button on the the style 
in the CSS Styles tab of the Design Panel 

 
 

From the pop-up menu, choose Export 
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The Export Styles as CSS File dialog box is displayed.  Enter a name for your style sheet file 
and click Save 

Applying an External Style Sheet 

After you have saved your page properties as 
an external style sheet, you can apply them 
right from the Design Panel   
 
First, either create a new page, or open an 
existing page to which you will apply the page 
properties. 
 
Click the Attach Style Sheet button in the CSS 
Styles tab of the Design Panel. 
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The Attach External Style Sheet dialog  box is displayed. 
 
 
Click the Browse button to select your external style sheet. 
 

 
 
Click on the style sheet name and click the OK button. 
 
The style sheet is attached, and your will see the page properties applied to your new page. 
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Saving Web Pages 
You can save a document using its current name and location, or save a copy of a document 
using a different name and location. 

When naming files, avoid using spaces and special characters in file and folder names. In 
particular, do not use special characters (such as é, ç, or ¥) or punctuation (such as colons, 
slashes, or periods) in the names of files you intend to put on a remote server; many servers 
change these characters during upload, which will cause any links to the files to break. Also, do 
not begin a filename with a numeral. 

To save a document: 

1. Do one of the following:  

o To overwrite the current version on the disk, and save any changes you have 
made, select File > Save.  

o To save the file in a different folder or using a different name, select File > Save 
As.  

2. In the Save As dialog box that appears, navigate to the folder where you want to save the 
file.  

3. In the File Name text box, type a name for the file.  

4. Click Save to save the file.  

 

Previewing and Testing Pages in Browsers 
You can preview a document in your target browsers at any time; you don’t have to save the 
document first.  

You can define up to 20 browsers for previewing. It’s a good idea to preview in the following 
browsers: Internet Explorer 6.0, Netscape Navigator 7.0, and the Macintosh-only Safari browser. 
In addition to these more popular, graphical browsers, you may want to test your pages using a 
text-only browser such as Lynx. 

To preview and test your document in a browser: 
1. Do one of the following to preview the page:  

o Select File > Preview in Browser from the menu, then select one of the listed 
browsers.  
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o Press F12 to display the current document in the primary browser.  

o Use the Preview in Browser button on the document toolbar.  

2. View ans test the content in your page.  

3. Close the page in the browser when you finish testing.  

To set or change preferences for your primary and secondary browsers: 

1. Do one of the following to open the Preview in Browser options:  
o Select Edit > Preferences (Windows) or Dreamweaver > Preferences (Macintosh), 

and then select Preview in Browser from the category list on the left.  
o Select File > Preview in Browser > Edit Browser List.  

The Preferences dialog box appears with the Preview in Browser options. 

2. Make changes as necessary.  

3. Click OK.  

 

Inserting and Formatting Text 
Macromedia Dreamweaver MX 2004 offers several ways for you to add and format text in a 
document. You can insert text, set font type, size, color, and alignment attributes, as well as 
create and apply your own custom styles using Cascading Style Sheet (CSS) styles. 

About formatting text 

Formatting text in Dreamweaver is similar to using a standard word processor. You can set 
default formatting styles (Paragraph, Heading 1, Heading 2, and so on) for a block of text, 
change the font, size, color, and alignment of selected text, or apply text styles such as bold, 
italic, code (monospace), and underline. 

By default, Dreamweaver formats text using Cascading Style Sheets (CSS) styles. CSS styles 
give web designers and developers greater control over web page design, while providing 
improved features for accessibility and reduced file size. As you style and align text using 
Dreamweaver formatting commands, CSS rules are embedded in the current document. This lets 
you more easily re-use existing styles that you create, as well as allowing you to name the styles 
you use. CSS is becoming the preferred method by which to format text and lay out web pages.  
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The Property Inspector and Text Formatting 

The text Property Inspector lets you style and format the currently selected text.  

• As you style and format text using the Property inspector, Dreamweaver keeps track of 
the formatting properties you assign to each text element, and assigns each a label using 
the naming convention: Style1, Style2, Style3, Stylen.  

 

• If you assign the same formatting attributes to two or more text elements, Dreamweaver 
labels those elements with the same title, eliminating redundant style names.  

• The label Dreamweaver applies to a given body of text can then be applied using the 
Style pop-up menu, letting you build a library of styles within a page, and apply those 
same styles by simply selecting the text element in the page and selecting a style from the 
Styles pop-up menu.  

• The Style pop-up menu displays both the names of styles in your page, as well as a 
preview of the style’s properties. The properties shown in the preview are font family, 
font size, font weight, text color, and background color. 

 

Formatting paragraphs 

Use the Format pop-up menu in the Property inspector or the Text > Paragraph Format 
submenu to apply the standard paragraph and heading tags.  

To apply a paragraph or heading tag:  

1. Place the insertion point in the paragraph, or select some of the text in the paragraph.  

2. Using the Text > Paragraph Format submenu or the Format pop-up menu in the Property 
inspector, select an option:  

o Select a paragraph format (for example, Heading 1, Heading 2, Preformatted 
Text, and so on). The HTML tag associated with the selected style (for example, 
h1 for Heading 1, h2 for Heading 2, pre for Preformatted text, and so on) is 
applied to the entire paragraph.  

o Select None to remove a paragraph format.  
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When you apply a heading tag to a paragraph, Dreamweaver automatically adds the next line of 
text as a standard paragraph. To change this setting, select Edit > Preferences (Windows) or 
Dreamweaver > Preferences (Macintosh); then in the General category, under Editing Options 
make sure Switch to Plain Paragraph after Heading is unchecked. 

Setting text property options 

The text Property inspector displays the current formatting attributes of the text that is selected in 
the document. You can change the formatting by setting new options. The style is immediately 
applied to the text.  

Setting and changing fonts and styles 

Use options in the Property inspector or the Text menu to set or change font characteristics for 
selected text. You can set the font type, style (such as bold or italic), and size. 

To set or change font characteristics: 

1. Select the text. If no text is selected, the change applies to subsequent text you type.  

2. Select from the following options:  

o To change the font, select a font combination from the Property inspector or from 
the Text > Font submenu.  

Select Default to remove previously applied fonts; Default applies the default font 
for the selected text (either the browser default font or the font assigned to that tag 
in the CSS style sheet). 

o To change the font style, click Bold or Italic in the Property inspector, or select a 
font style (Bold, Italic, Underline, and so on) from the Text > Style submenu.  

Note: When you use the Property inspector to apply bold or italic style, 
Dreamweaver automatically applies the <strong> or <em> tag, respectively. If 
you are designing pages for viewers with 3.0 or older version browsers, you 
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should change this preference in the General category of the Preferences dialog 
box (Edit > Preferences). 

o To change the font size, select a size (1 through 7) from the Property inspector or 
from the Text > Size submenu.  

HTML font sizes are relative, not specific, point sizes. Users set the point size of 
the default font for their browsers; this is the font size that they will see when you 
select Default or 3 in the Property inspector or Text > Size submenu. Sizes 1 and 
2 will appear smaller than the default font size; sizes 4 through 7 will appear 
larger. Also, fonts generally look larger in Windows than on the Macintosh, 
though Macintosh Internet Explorer 5 uses the same default font size as Windows. 

Tip: One way to ensure consistency with font size is to use CSS styles with your 
font size set in pixels.  

To increase or decrease the size of selected text, select a relative size (+ or –1 to + 
4 or –3) from the Property inspector or from either the Text > Size Change 
submenu.  

Note: These numbers indicate a relative difference from the basefont size. The 
default basefont value is 3. Thus, a +4 value results in a font size of 3 + 4, or 7. 
The maximum sum for your font size values is 7. If you try to set them higher, 
they appear as 7. Dreamweaver does not display the basefont tag (which goes in 
the head section), although the font size should appear properly in a browser. To 
test this, compare text set at 3 and text set at +3. 

Changing the text color 

You can change the color of selected text so that the new color overrides the text color set in 
Page Properties. (If no text color has been set in Page Properties, the default text color is black.) 

To change the color of text: 

1. Select the text.  

2. Select a color from the palette by clicking the color picker in the Property inspector.  

To return text to the default color: 

1. In the Property inspector, click the color box to open the palette of web-safe colors.  

2. Click the Strike-through button (the white square button with a red line through it, found 
in the upper right corner).  
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Checking Spelling 
Use the Check Spelling command in the Text menu to check the spelling in the current1 
document. The Check Spelling command ignores HTML tags and attribute values.  

By default, the spelling checker uses the U.S. English spelling dictionary. To change the 
dictionary, select Edit > Preferences > General (Windows) or Dreamweaver > Preferences > 
General (Macintosh), then in the Spelling Dictionary pop-up menu select the dictionary you want 
to use. Dictionaries for additional languages can be downloaded from the Dreamweaver Support 
Center at www.macromedia.com/support/dreamweaver. 

To check and correct spelling: 

1. Select Text > Check Spelling or press Shift+F7.  

When Dreamweaver encounters an unrecognized word the Check Spelling dialog box 
appears. 

 

2. Select the appropriate option based on how you want the discrepancy handled.  
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Inserting Images 
About Image Formats 

Many different types of graphic file formats exist, but three graphic file formats are generally 
used in web pages--GIF, JPEG, and PNG. Currently, GIF and JPEG file formats are the best 
supported and can be viewed by most browsers.  

PNG files are best suited for almost any type of web graphic due to their flexibility and small file 
size; however, the display of PNG images is only partially supported in Microsoft Internet 
Explorer (4.0 and later browsers) and Netscape Navigator (4.04 and later browsers). So unless 
you are designing for a specific target audience using a browser that supports the PNG format, 
use GIFs or JPEGs for broader accessibility. 

GIF (Graphic Interchange Format) files use a maximum of 256 colors, and are best for 
displaying noncontinuous-tone images or those with large areas of flat colors, such as navigation 
bars, buttons, icons, logos, or other images with uniform colors and tones.  

JPEG (Joint Photographic Experts Group) file format is the superior format for photographic 
or continuous-tone images, because JPEG files can contain millions of colors. As the quality of a 
JPEG file increases, so does the file size and the file download time. You can often strike a good 
balance between the quality of the image and the file size by compressing a JPEG file.  

PNG (Portable Network Group) file format is a patent-free replacement for GIFs that includes 
support for indexed-color, gray scale, and true-color images, and alpha channel support for 
transparency. PNG is the native file format of Macromedia Fireworks. PNG files retain all the 
original layer, vector, color, and effects information (such as drop shadows), and all elements are 
fully editable at all times. Files must have the .png file extension to be recognized as PNG files 
by Dreamweaver. 

 

To add an image to your page: 

1. Save your page if you haven’t already done so.  

You can insert an image into an unsaved document, but if you do, a dialog box appears, 
informing you that the URL used for the image will be the full local path to the image. 
Dreamweaver fixes the URL later, when you do save the document, but it’s easiest to 
save the document before adding images.  
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2. Click the Images button on the Common Insert Bar 

3. The Select Image Source dialog box is displayed.  

 

4. Browse to the image you wish to use, select it and click OK. 

 

Editing Images in Dreamweaver 

Dreamweaver provides basic image-editing features that let you modify images without having 
to use an external image-editing application such as Macromedia Fireworks or Adobe 
Photoshop. The Dreamweaver image-editing tools are designed to let you easily work with 
content designers responsible for creating image files for use on your website.  

Dreamweaver has the following image-editing features: 

Image resampling adds or subtracts pixels from a resized JPEG and GIF image files to match 
the appearance of the original image as closely as possible. Resampling an image reduces an 
images file size, resulting in improved download performance. 

When you resize an image in Dreamweaver, you can resample it to accommodate its new 
dimensions. When a bitmap object is resampled, pixels are added to or removed from the image 
to make it larger or smaller. Resampling an image to a higher resolution typically causes little 
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loss of quality. Resampling to a lower resolution, however, always causes data loss and usually a 
drop in quality. 

Cropping lets you edit images by reducing the area of the image. Typically, you’ll want to crop 
an image to place more emphasis on the subject of the image, and remove unwanted aspects 
surrounding the center of interest in the image.  

Brightness/Contrast modifies the contrast or brightness of pixels in an image. This affects the 
highlights, shadows, and midtones of an image. You typically use Brightness/Contrast when 
correcting images that are too dark or too light. 

Sharpening adjusts the focus of an image by increasing the contrast of edges found within the 
image. When you scan an image, or take a digital photo, the default action of most image 
capturing software is to soften the edges of objects in the image. This prevents extremely fine 
details from becoming lost in the pixels from which digital images are composed. However, to 
bring out the details in digital image files, it is often necessary to sharpen the image, thereby 
increasing edge contrast, and making the image appear sharper. 

Note: Dreamweaver image-editing features apply only to JPEG and GIF image file formats. 
Other bitmap image file formats cannot be edited using these image-editing features. 

Resizing an image 

Visually resizing an image in Dreamweaver helps you to see how the image affects the layout at 
different dimensions. Visually resizing an image does not scale the image file to the proportions 
that you specify. If you do visually resize an image in Dreamweaver, but don’t use an image-
editing application (such as Macromedia Fireworks) to scale the image file to the desired size, 
the user’s browser has to scale the image when the page is loaded. This may cause both a delay 
in page download time and the improper display of the image in the user’s browser. To reduce 
download time and to ensure that all instances of an image appear at the same size, use an 
image-editing application to scale images. 

To visually resize an image: 

1. Select the image  

Resize handles appear at the bottom and right sides of the element and in the bottom right 
corner. If resize handles don’t appear, either click somewhere other than the element you 
want to resize and then reselect it, or click the appropriate tag in the tag selector to select 
the element. 

2. Resize the element by doing one of the following:  
o To adjust the width of the element, drag the selection handle on the right side.  
o To adjust the height of the element, drag the bottom selection handle.  
o To adjust the width and the height of the element at the same time, drag the corner 

selection handle.  
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o To preserve the element’s proportions (its width-to-height ratio) as you adjust its 
dimensions, Shift-drag the corner selection handle.  

Elements can be visually resized to a minimum of 8 x 8 pixels. To adjust the width and height of 
an element to a smaller size (for example, 1 x 1 pixel), use the Property inspector to enter a 
numeric value. 

To return a resized element to its original dimensions, in the Property inspector, delete the values 
in the W and H text box, or click the Reset Size button.  

To revert an image to its original size: 

• Click the Reset size button in the image Property inspector.  

 

To resample a resized image: 

1. Resize the image as described above.  
2. Click the Resample button in the image Property inspector. 

 

Note: You can not resample image placeholders or elements other than bitmap images. 

 

Cropping an image 

Dreamweaver lets you crop (or trim) bitmap file images.  When you crop an image using 
Dreamweaver, the source image file is changed on disk. for this reason, you may want to keep a 
backup copy of the image file in the event you need to revert to the original image. 

To crop an image file: 

1. Open the page containing the image you want to crop and select the image 

2. Click the Crop Tool icon in the image Property inspector. 
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3. Crop handles appear around the selected image.  Adjust the crop handles until the 
bounding box surrounds the area of the image that you want to keep.  

 

4. Double-click inside the bounding box or press Enter to crop the selection.  

 

 

5. A dialog box informs you that the image file you are cropping will be changed on 
disk. Click OK.  

6. Every pixel in the selected bitmap outside the bounding box is removed, but other 
objects in the image remain.  

7. Preview the image and ensure that it meets your expectations.  

 

 

To undo the effects of the crop command: 

• Select Edit > Undo Crop to revert to the original image.  
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Linking and Navigation 
There are several different ways of creating and managing links. Some web designers prefer to 
create links to nonexistent pages or files as they work, while others prefer to create all the files 
and pages first and then add the links. Another way to manage links is to create placeholder 
pages, which stand in for the final file and let you add links quickly and check them before you 
have actually completed all the pages. 

Understanding document locations and paths 

Understanding the file path between the document you’re linking from and the document you’re 
linking to is essential to creating links. 

There are three types of link paths: 

• Absolute paths 

(example: http://www.macromedia.com/support/dreamweaver/contents.html).  

• Document-relative paths 

 (example: dreamweaver/contents.html).  

• Site root-relative paths 

 (example: /support/dreamweaver/contents.html).  

Using Dreamweaver, you can easily select the type of document path to create for your links  

 

Absolute paths 

Absolute paths provide the complete URL of the linked document, including the protocol to use 
(usually http:// for web pages). For example, 
http://www.macromedia.com/support/dreamweaver/contents.html is an absolute path.  

You must use an absolute path to link to a document on another server. While you can also use 
absolute-path links for local links (to documents in the same site), that approach is discouraged--
if you move the site to another domain, all of your local absolute-path links will break. Using 
relative paths for local links also provides greater flexibility if you need to move files within 
your site. 
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Note: When inserting images (not links): if you use an absolute path to an image that resides on 
a remote server and is not available on the local hard drive, you will not be able to view the 
image in your document window. Instead, you must preview the document in a browser to see it. 

Document-relative paths 

Document-relative paths are the most appropriate paths to use for local links in most websites. 
They’re particularly useful when the current document and the linked document are in the same 
folder and are likely to remain together. You can also use a document-relative path to link to a 
document in another folder by specifying the path through the folder hierarchy from the current 
document to the linked document.  

The basic idea of document-relative paths is to omit the part of the absolute URL that is the same 
for both the current document and the linked document, providing only the portion of the path 
that differs.  

Site root-relative paths 

Site root-relative paths provide the path from the site’s root folder to a document. You may want 
to use these types of paths if you are working on a large website that uses several servers, or one 
server that hosts several different sites. However, if you are not familiar with this type of path, 
you may want to stick to document-relative paths. 

A site root-relative path begins with a leading forward slash, which stands for the site root folder. 
For example, /support/tips.html is a site root-relative path to a file (tips.html) in the support 
subfolder of the site’s root folder.  

A site root-relative path often provides the best way to specify links in a website in which you 
need to frequently move HTML files from one folder to another. When you move a document 
that contains root-relative links, you don’t need to change the links; for example, if your HTML 
files use root-relative links for dependent files (such as images), then if you move an HTML file, 
its dependent-file links are still valid. 

However, when you move or rename the documents linked to with root-relative links, you do 
need to update those links, even if the documents’ paths relative to each other haven’t changed. 
For example, if you move a folder, all root-relative links to files within that folder must be 
updated. (If you move or rename files using the Files panel, Dreamweaver updates all relevant 
links automatically.) 
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Creating Links 
You can create several types of links in a document: 

• A link to another document or to a file, such as a graphic, movie, PDF, or sound file.  

• A named anchor link, which jumps to a specific location within a document.  

• An e-mail link, which creates a new blank e-mail message with the recipient’s address 
already filled in.  

Linking Documents using Point-to-File  

The Point-to-File icon lets you create links from an image, an object, or text to another document 
or file.  

To link documents using the Point-to-File icon: 

1. Select text or an image in the Document window’s Design view.  

2. Drag the Point-to-File icon  at the right of the Link text box in the Property 
inspector and point to another open document, a visible anchor in an open document, or a 
document in the Files panel.  
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The Link text box updates to show the link. 

Note: You can link to an open document only if your documents are not maximized in 
the Document window. When you point to an open document, that document moves to 
the foreground of your screen while you are making your selection. 

3. Release the mouse button.  

 

Checking for broken, external, and orphaned links 

Use the Check Links feature to search for broken links and unreferenced--also known as 
orphaned--files (files that still exist in the site but no other files in the site link to) in an open file, 
a portion of a local site, or an entire local site.  

The only links that Dreamweaver verifies are links to documents within the site; Dreamweaver 
compiles a list of external links that appear in the selected document or documents, but does not 
verify them. 
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To check links within the current document: 

1. Save the file to a location within your local Dreamweaver site.  
2. Select File > Check Page > Check Links.  

The Broken Links report appears in the Link Checker panel (in the Results panel group). 

3. In the Link Checker panel, select External Links from the Show pop-up menu to view 
another report.  

The External Links report appears in the Link Checker panel (in the Results panel group). 

Tip: You can check for orphaned files when you check links across an entire site. 

4. To save the report, click the Save Report button in the Link Checker panel.  

Note: The target browser report is a temporary file--it will be lost if you don’t save it. 

Fixing broken links  

To fix links in the Property inspector:  

1. Run a link check report . 
2. In the Link Checker panel (in the Results panel group), double-click an entry in the 

File column.  

Dreamweaver opens the document, selects the offending image or link, and highlights the 
path and filename in the Property inspector. (If the Property inspector is not visible, select 
Window > Properties to open it.) 

3. To set a new path and filename in the Property inspector, click the folder icon to browse 
to the correct file, or type over the highlighted text.  

If you are updating an image reference and the new image appears at the incorrect size, 
click the W and H labels in the Property inspector or click the Refresh button to reset the 
height and width values. The W and H labels change from bold to normal type. 

4. Save the file.  

As links are fixed, their entries disappear from the Link Checker list. If an entry still appears in 
the list after you enter a new path or filename in the Link Checker (or after you save changes in 
the Property inspector), it means that Dreamweaver cannot find the new file and still considers 
the link broken. 
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Presenting Content with Tables 
Tables are a powerful tool for presenting tabular data and for laying out text and graphics on 
a page. 

Many designers use tables to lay out web pages. Macromedia Dreamweaver MX 2004 provides 
two ways to view and manipulate tables: Standard mode, in which tables are presented as a grid 
of rows and columns, and Layout mode, which allows you to draw, resize, and move boxes on 
the page while still using tables for the underlying structure  

To insert a table: 

1. In the Design view of the Document window, place the insertion point where you want 
the table to appear.  

Note: If your document is blank, then the only place you can place the insertion point is 
at the beginning of the document. 

2. Do one of the following:  

o Select Insert > Table.  

o In the Common category of the Insert bar, click the Table button.  

 

 

The Insert Table dialog box appears. 
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3. Complete the dialog box.  

4. Click OK.  

The table appears in the document. 
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Setting the Insert Table dialog box options 

1. In the Table Size section, specify the following options:  

Rows determines the number of rows the table has. 

Columns determines the number of columns the table has. 

Table Width specifies the width of the table in pixels, or as a percentage of the browser 
window’s width. 

Border Thickness specifies the width, in pixels, of the table’s borders. 

Tip: If you don’t explicitly assign a value for the border thickness, most browsers display 
the table as if the border thickness were set to 1. To ensure that browsers display the table 
with no border, set the border thickness to 0. To view cell and table boundaries when the 
border thickness is set to 0, select View > Visual Aids > Table Borders. 

Cell Padding determines the number of pixels between a cell’s border and its contents. 

Cell Spacing determines the number of pixels between adjacent table cells. 

Tip: When you don’t explicitly assign values for cell spacing and cell padding, most 
browsers display the table as if cell padding were set to 1 and cell spacing were set to 2. 
To ensure that browsers display the table with no padding or spacing, set Cell Padding 
and Cell Spacing to 0. 

2. In the Header section, select one of the header options:  

None does not enable column or row headings for the table. 

Left makes the first column of the table a column for headings, so that you can enter a 
heading for each row of the table.  

Top makes the first row of the table a row for headings, so that you can enter a heading 
for each column of the table. 

Both enables you to enter column and row headings in the table. 

Tip: It’s a good idea to use headers in case any of your website visitors use screen 
readers. Screen readers read table headings and help screen-reader users keep track of 
table information,  
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3. In the Accessibility section, specify the following options:  

Caption provides a table title which displays outside of the table. 

Align Caption specifies where the table caption appears in relation to the table. 

Summary provides a table description. Screen readers read the summary text, but the 
text does not appear in the user’s browser. 

4. Click OK to create the table.  

 

To view and set table or table element properties: 

1. Select a table, cell, row, or column 

2. In the Property inspector (Window > Properties), click the expander arrow in the lower 
right corner to see all the properties.  

 

 

3. Change properties as necessary.  

Note: When you set properties on a column, Dreamweaver changes the attributes of the 
td tag corresponding to each cell in the column. When you set certain properties for a 
row, however, Dreamweaver changes the attributes of the tr tag rather than changing the 
attributes of each td tag in the row, When you’re applying the same format to all the cells 
in a row, applying the format to the tr tag produces cleaner, more concise HTML code. 

 

Resizing tables, columns, and rows 

You can resize an entire table or individual rows and columns. If you have trouble resizing, you 
can clear the column widths or row heights and start over.  

Sometimes the column widths set in the HTML code do not match their apparent widths on the 
screen. When this happens, you can make the widths consistent. Table and column widths and 
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header menus appear in Dreamweaver to help you lay out your tables; you can turn the widths 
and menus on and off as necessary. 

Resizing a table 

You can resize a table by dragging one of its selection handles. Dreamweaver displays the table 
width, along with a table header menu, at the top or bottom of the table when the table is selected 
or the insertion point is in the table.  

When you resize an entire table, all of the cells in the table change size proportionately. If a 
table’s cells have explicit widths or heights specified, resizing the table changes the visual size of 
the cells in the Document window but does not change the specified widths and heights of the 
cells.. 

To resize a table: 

1. Select the table . 

Selection handles appear on the table. 

2. Do one of the following:  
o To resize the table horizontally, drag the selection handle on the right.  
o To resize the table vertically, drag the selection handle on the bottom.  
o To resize the table in both dimensions, drag the selection handle at the lower right 

corner.  

Resizing columns and rows 

You can change the width of a column or the height of a row in the Property inspector or by 
dragging the borders of the column or row. If you have trouble resizing, you can clear the 
column widths or row heights and start over . 

Dreamweaver displays column widths, along with column header menus, at the tops or bottoms 
of columns when the table is selected or the insertion point is in the table.). 

To change a column’s width and keep the overall table width: 

• Drag the right border of the column you want to change.  

The width of the adjacent column also changes, so you actually resize two columns. 
Visual feedback shows you how the columns will adjust; the overall table width does not 
change. 

Note: In tables with percentage-based widths (not pixels), if you drag the right border of 
the rightmost column, the whole table’s width changes, and all of the columns grow 
wider or narrow proportionately. 
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To change a column’s width and maintain the size of the other columns: 

• Hold the Shift key, then drag the column’s border.  

The width of one column changes. Visual feedback shows you how the columns will 
adjust; the overall table width changes to accommodate the column you are resizing.  

 
To change a row’s height visually: 

• Drag the lower border of the row.  

To set a column’s width or a row’s height using the Property inspector: 

1. Select the column or row. 
2. In the Property inspector (Window > Properties), enter a value in the W text field for the 

column’s width or in the H text field for the row’s height.  

Tip: You can specify widths and heights as either pixels or percentages, and you can 
convert from pixels to percentages and back. 

3. Press Tab or Enter (Windows) or Return (Macintosh) to apply the value.  

Making column widths in code consistent with visual widths 

If you see two numbers for a column’s width, then the column width set in the HTML code does 
not match the column’s apparent width on the screen. You can make the width specified in the 
code match the visual width.  

To make widths consistent: 

1. Click in a cell.  

2. Click the table header menu, then select Make All Widths Consistent.  

Dreamweaver resets the width specified in the code to match the visual width. 

 

Clearing set widths and heights 

You might want to clear set widths and heights before you resize a table, or if you have trouble 
resizing a table or individual columns or rows and want to start over. 
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Note: When you resize a table by dragging one of its selection handles, you change the visual 
size of the cells in the table, but you do not change any specified widths or heights of cells. It’s a 
good idea to clear set widths and heights before resizing. 

To clear all set widths or heights in a table: 

1. Select the table. 

2. Do one of the following:  

o Select Modify > Table > Clear Cell Widths or Modify > Table > Clear Cell 
Heights.  

o In the Property inspector (Window > Properties), click the Clear Row Heights 
button or the Clear Column Widths button.  
Click the table header menu, then select Clear All Heights or Clear All Widths.  

To clear a column’s set width: 

1. Click in the column.  
2. Click the column header menu, then select Clear Column Width.  

Setting cell, row, and column properties 

This Property inspector allows you to set properties for table elements (cells, row, and columns). 

Note: When you set properties on a column, Dreamweaver changes the attributes of the td tag 
corresponding to each cell in the column. When you set certain properties for a row, however, 
Dreamweaver changes the attributes of the tr tag rather than changing the attributes of each td tag 
in the row, When you’re applying the same format to all the cells in a row, applying the format 
to the tr tag produces cleaner, more concise HTML code. 

To set properties for a table element: 

Set any of the following options:  

Horz specifies the horizontal alignment of the contents of a cell, row, or column. You can align 
the contents to the left, right, or center of the cells, or you can indicate that the browser should 
use its default alignment (usually left for regular cells and center for header cells). 

Vert specifies the vertical alignment of the contents of a cell, row, or column. You can align the 
contents to the top, middle, bottom, or baseline of the cells, or indicate that the browser should 
use its default alignment (usually middle). 

W and H are the width and height of selected cells in pixels, or as a percentage of the entire 
table’s width or height. To specify a percentage, follow the value with a percent symbol (%). To 

Copyright 2003 Macromedia®  Page 52 
Excerpted from Macromedia Dreamweaver® MX 2004 Help  Document 



let the browser determine the proper width or height based on the contents of the cell and the 
widths and heights of the other columns and rows, leave the field blank (the default). 

By default, a browser chooses a column width to accommodate the widest image or the longest 
line in a column. This is why a column sometimes becomes much wider than the other columns 
in the table when you add content to it. 

By default, a browser chooses a row height to accommodate all the text and images in the row. 

Note: You can specify a height as a percentage of the total table height, but the row may not 
display at the specified percentage height in browsers. 

Bg (upper text field) is the filename for the background image for a cell, column, or row. Click 
the folder icon to browse to an image, or use the Point-to-File icon to select an image file. 

Bg (lower color swatch and text field) is the background color for a cell, column, or row, 
chosen with the color picker. 

Brdr is the border color for the cells. 

Merge Cells button combines selected cells, rows, or columns into one cell (see Splitting and 
merging cells). You can merge cells only if they form a rectangular or linear block. 

Split Cell button divides a cell, creating two or more cells (see Splitting and merging cells). You 
can split only one cell at a time; this button is disabled if more than one cell is selected. 

No Wrap prevents line wrapping, keeping all the text in a given cell on a single line. If No Wrap 
is enabled, cells widen to accommodate all data as you type it or paste it into a cell. (Normally, 
cells expand horizontally to accommodate the longest word or widest image in the cell, then 
expand vertically as necessary to accommodate other contents.) 

Header formats the selected cells as table header cells. The contents of table header cells are 
bold and centered by default.  

If you entered a value in a text box, press Tab or Enter (Windows) or Return (Macintosh) to 
apply the value.  
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Publishing Your Site 
Site testing guidelines 

Publishing your site--that is, making it live--can be accomplished in several ways and is an 
ongoing process.  Before uploading your site to a server and declaring it ready for viewing, it’s a 
good idea to test it locally. (In fact, it’s a good idea to test and troubleshoot your site frequently 
throughout its construction--you can catch problems early and avoid repeating them.)  

You should make sure that your pages look and work as expected in the browsers you’re 
targeting, that there are no broken links, and that the pages don’t take too long to download. You 
can also test and troubleshoot your entire site by running a site report. 

The following guidelines will help you create a good experience for visitors to your site: 

• Make sure your pages function as expected in the browsers you’re targeting and that 
they either work or "fail gracefully" in other browsers.  

• Preview your pages in as many different browsers and on as many different platforms 
as possible.  

• This gives you an opportunity to see differences in layout, color, font sizes, and 
default browser window size that cannot be predicted in a target browser check  

• Check your site for broken links, then fix them.  

• Keep in mind that if you are using external links in your site, other sites undergo 
redesign and reorganization too, and the page you’re linking to may have been moved 
or deleted.  

• Monitor the file size of your pages and the time they take to download . 

• Keep in mind that if a page consists of one large table, in some browsers, visitors will 
see nothing until the entire table finishes loading. Consider breaking up large tables; 
if this is not possible, consider putting a small amount of content--such as a welcome 
message or an advertising banner--outside the table at the top of the page so users can 
view this material while the table downloads. 

• Once the bulk of the site has been published, continue to update and maintain it.  

• Use the Dreamweaver discussion forums found on the Macromedia website at 
www.macromedia.com/go/dreamweaver_newsgroup.   The forums are a great 
resource for getting information on different browsers, platforms, and so on. You can 
also discuss technical issues and share helpful hints with other Dreamweaver users. 
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Viewing Your Site Locations 

In the files Panel, you can access, modify, and save files and folders in your Dreamweaver sites, 
as well as files and folders that are not part of a Dreamweaver site. In addition to Dreamweaver 
sites, you can access a server, a local drive, or your desktop.  

 

Using the Expand button  in the Files 
panel, you can display a full screen view of 
your local and remote site locations. 
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To publish your site: 
 
If you have not yet set up your remote site location, you must do so before publishing. 
 

1. Click the define a remote site link in the files window. 
 

The Site Definition dialog box is displayed.  
 

 
 

2. Select the appropriate remote server connection (in our example we are using 
Local/Network) 
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3. Use the Folder Icon to browse to and select the remote location. 

 

 
 

4. Click the Next button twice (we are skipping the Check-In/Check-Out option here). 
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5. Click the Done button to finish defining the remote site location to Dreamweaver. 
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When you return to the Files Window, simply drag and drop all of the pages and folders from 
your local site onto the site folder icon in the Remote Site Panel. 
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More Resources 
 
In Macromedia Dreamweaver’s Help Menu: 

Macromedia provides Getting Started and 
Tutorials to help you get started with 
Dreamweaver.  Both are easy to use and very 
helpful if you are new to Dreamweaver and 
web design. 
 
Using Dreamweaver is a cop yof the complete 
user’s guide for Dreamweaver (700+ pages!) 
and covers all fo Dreamwweaver’s features in 
detail.  If you like comprehensive manuals, you 
can print this out and put it in a binder for 
future reference 

 
 
 
A good book for learning Dreamweaver:  
 
Macromedia Dreamweaver MX 2004 Hands-On Training , Garo Green with Lynda Weinman 
 
…and Lynda’s website: www.lynda.com 
 
 
 
If you are interested in learning more about HTML try this book: 
 
HTML for the Worldwide Web, Elizabeth Castro, Peachpit Press 
 
 
 
 
If you would like a humorous approach to leaning effective web design, do try  
www.websitesthatsuck.com 
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